import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?<tagName>\\w+)((>)|(.+?>))(.+?)?<\\/\\k<tagName>>";
final String string = "<transaction>\n"
+ " <id>6753322</id>\n"
+ " <number region=\"Russia\">8-900-000-00-00</number>\n"
+ " <nonattr />\n"
+ " <nonattr></nonattr>\n"
+ " <nonattr>text</nonattr>\n"
+ " <attr id=\"1\" />\n"
+ " <attr id=\"2\"></attr>\n"
+ " <attr id=\"3\">text</attr>\n"
+ " <email>\n"
+ " <to>to_example@gmail.com</to>\n"
+ " <from>from_example@gmail.com</from>\n"
+ " <subject>Project discussion</subject>\n"
+ " <body font=\"Verdana\">Body message</body>\n"
+ " <date day=\"12\" month=\"12\" year=\"2018\"/>\n"
+ " </email>\n"
+ "</transaction>\n\n"
+ "<number region=\"Russia\">8-900-000-00-00</number>\n\n\n"
+ "<nonattr></nonattr>\n\n"
+ "<attr id=\"2\"></attr>\n\n"
+ "<body font=\"Verdana\">Body message</body>\n\n"
+ " <email>\n"
+ " <to>to_example@gmail.com</to>\n"
+ " <from>from_example@gmail.com</from>\n"
+ " <subject>Project discussion</subject>\n"
+ " <body font=\"Verdana\">Body message</body>\n"
+ " <date day=\"12\" month=\"12\" year=\"2018\"/>\n"
+ " </email>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}