const regex = /<(?<tagName>\w+)((>)|(.+?>))(.+?)?<\/\k<tagName>>/mgs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?<tagName>\\w+)((>)|(.+?>))(.+?)?<\\\/\\k<tagName>>', 'mgs')
const str = `<transaction>
<id>6753322</id>
<number region="Russia">8-900-000-00-00</number>
<nonattr />
<nonattr></nonattr>
<nonattr>text</nonattr>
<attr id="1" />
<attr id="2"></attr>
<attr id="3">text</attr>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font="Verdana">Body message</body>
<date day="12" month="12" year="2018"/>
</email>
</transaction>
<number region="Russia">8-900-000-00-00</number>
<nonattr></nonattr>
<attr id="2"></attr>
<body font="Verdana">Body message</body>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font="Verdana">Body message</body>
<date day="12" month="12" year="2018"/>
</email>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}