# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(?<tagName>\w+)((>)|(.+?>))(.+?)?<\/\k<tagName>>"
test_str = ("<transaction>\n"
" <id>6753322</id>\n"
" <number region=\"Russia\">8-900-000-00-00</number>\n"
" <nonattr />\n"
" <nonattr></nonattr>\n"
" <nonattr>text</nonattr>\n"
" <attr id=\"1\" />\n"
" <attr id=\"2\"></attr>\n"
" <attr id=\"3\">text</attr>\n"
" <email>\n"
" <to>to_example@gmail.com</to>\n"
" <from>from_example@gmail.com</from>\n"
" <subject>Project discussion</subject>\n"
" <body font=\"Verdana\">Body message</body>\n"
" <date day=\"12\" month=\"12\" year=\"2018\"/>\n"
" </email>\n"
"</transaction>\n\n"
"<number region=\"Russia\">8-900-000-00-00</number>\n\n\n"
"<nonattr></nonattr>\n\n"
"<attr id=\"2\"></attr>\n\n"
"<body font=\"Verdana\">Body message</body>\n\n"
" <email>\n"
" <to>to_example@gmail.com</to>\n"
" <from>from_example@gmail.com</from>\n"
" <subject>Project discussion</subject>\n"
" <body font=\"Verdana\">Body message</body>\n"
" <date day=\"12\" month=\"12\" year=\"2018\"/>\n"
" </email>\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.