import Foundation
let pattern = #"<(?<tagName>\w+)((>)|(.+?>))(.+?)?<\/\k<tagName>>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<transaction>
<id>6753322</id>
<number region="Russia">8-900-000-00-00</number>
<nonattr />
<nonattr></nonattr>
<nonattr>text</nonattr>
<attr id="1" />
<attr id="2"></attr>
<attr id="3">text</attr>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font="Verdana">Body message</body>
<date day="12" month="12" year="2018"/>
</email>
</transaction>
<number region="Russia">8-900-000-00-00</number>
<nonattr></nonattr>
<attr id="2"></attr>
<body font="Verdana">Body message</body>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font="Verdana">Body message</body>
<date day="12" month="12" year="2018"/>
</email>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)