// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<(?<tagName>\w+)((>)|(.+?>))(.+?)?<\/\k<tagName>>").unwrap();
let string = "<transaction>
<id>6753322</id>
<number region=\"Russia\">8-900-000-00-00</number>
<nonattr />
<nonattr></nonattr>
<nonattr>text</nonattr>
<attr id=\"1\" />
<attr id=\"2\"></attr>
<attr id=\"3\">text</attr>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font=\"Verdana\">Body message</body>
<date day=\"12\" month=\"12\" year=\"2018\"/>
</email>
</transaction>
<number region=\"Russia\">8-900-000-00-00</number>
<nonattr></nonattr>
<attr id=\"2\"></attr>
<body font=\"Verdana\">Body message</body>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font=\"Verdana\">Body message</body>
<date day=\"12\" month=\"12\" year=\"2018\"/>
</email>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}