const regex = /public (\w*?) ([A-Z])(\w*?) { get; set; }/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public (\\w*?) ([A-Z])(\\w*?) { get; set; }', 'gm')
const str = ` public string TenLop { get; set; }
public int TongSoHocSinh { get; set; }
public int SoNam { get; set; }
public int SoNu { get; set; }
public int SoNhoHon18Th { get; set; }
public int SoTu18ThDen3T { get; set; }
public int SoTu3TDen4T { get; set; }
public int SoTu4TDen5T { get; set; }
public int SoLonHon5T { get; set; }
`;
const subst = `\L$2\E$3: $1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);