// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)public (\w*?) ([A-Z])(\w*?) { get; set; }").unwrap();
let string = " public string TenLop { get; set; }
public int TongSoHocSinh { get; set; }
public int SoNam { get; set; }
public int SoNu { get; set; }
public int SoNhoHon18Th { get; set; }
public int SoTu18ThDen3T { get; set; }
public int SoTu3TDen4T { get; set; }
public int SoTu4TDen5T { get; set; }
public int SoLonHon5T { get; set; }
";
let substitution = "\\L$2\\E$3: $1;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}