# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"public (\w*?) ([A-Z])(\w*?) { get; set; }"
test_str = (" public string TenLop { get; set; }\n"
" public int TongSoHocSinh { get; set; }\n"
" public int SoNam { get; set; }\n"
" public int SoNu { get; set; }\n"
" public int SoNhoHon18Th { get; set; }\n"
" public int SoTu18ThDen3T { get; set; }\n"
" public int SoTu3TDen4T { get; set; }\n"
" public int SoTu4TDen5T { get; set; }\n"
" public int SoLonHon5T { get; set; }\n")
subst = "\\L$2\\E$3: $1;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.