#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){[^{}]*'[xyz]_acc'[^{}]*}"
Local $sString = "{'device_id': 'M123'}" & @CRLF & _
"{'x_acc': 0.00, 'y_acc' : 0.01, 'z_acc' : 1.02}" & @CRLF & _
"{'device_id': 'S123'}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")