import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\{\\}]*'[xyz]_acc'[^\\{\\}]*\\}";
final String string = "{'device_id': 'M123'}\n"
+ "{'x_acc': 0.00, 'y_acc' : 0.01, 'z_acc' : 1.02}\n"
+ "{'device_id': 'S123'}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}