use strict;
my $str = '{\'device_id\': \'M123\'}
{\'x_acc\': 0.00, \'y_acc\' : 0.01, \'z_acc\' : 1.02}
{\'device_id\': \'S123\'}
';
my $regex = qr/{[^{}]*'[xyz]_acc'[^{}]*}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}