package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){[^{}]*'[xyz]_acc'[^{}]*}`)
var str = `{'device_id': 'M123'}
{'x_acc': 0.00, 'y_acc' : 0.01, 'z_acc' : 1.02}
{'device_id': 'S123'}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}