$re = '/{[^{}]*\'[xyz]_acc\'[^{}]*}/m';
$str = '{\'device_id\': \'M123\'}
{\'x_acc\': 0.00, \'y_acc\' : 0.01, \'z_acc\' : 1.02}
{\'device_id\': \'S123\'}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);