#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ui)[^\P{L}a-z]+(\.[^\P{L}a-z]+)+"
Local $sString = " abcd.com 普遍接受测试.世界 ya.ru домен.рф abcd.com "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)