using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\P{L}a-z]+(\.[^\P{L}a-z]+)+";
string substitution = @"";
string input = @" abcd.com 普遍接受测试.世界 ya.ru домен.рф abcd.com ";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}