using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<!])((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))";
string input = @"The text [.underline]#underline me# is underlined. +
The text [.line-through]#aaa# ist durchgestrichen.
text #just highlight#, normal tex#t#fg#f#gfg
#ffsfsdf fdsfsd#
TODO: wrong marking
The *[red]##c##[green]##o##[purple]##l##[fuchsia]##o##[blue]##r##* brings contrast to the text, making it easier to read.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}