re = /(?m)(?<!])((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))/m
str = 'The text [.underline]#underline me# is underlined. +
The text [.line-through]#aaa# ist durchgestrichen.
text #just highlight#, normal tex#t#fg#f#gfg
#ffsfsdf fdsfsd#
TODO: wrong marking
The *[red]##c##[green]##o##[purple]##l##[fuchsia]##o##[blue]##r##* brings contrast to the text, making it easier to read.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end