using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^_]*";
string substitution = @"b";
string input = @"a_a_a";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}