use strict;
my $str = 'a_a_a';
my $regex = qr/[^_]*/p;
my $subst = 'b';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";