package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^_]*`)
var str = `a_a_a`
var substitution = "b"
fmt.Println(re.ReplaceAllString(str, substitution))
}