const regex = /[^_]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^_]*', 'g')
const str = `a_a_a`;
const subst = `b`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);