#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)AB_INV_(?![5-9]_)\d{1,4}_"
Local $sString = "AB_INV_23_some_value" & @CRLF & _
"AB_INV_234_some_value" & @CRLF & _
"AB_INV_23456_some_value" & @CRLF & _
"AB_INV_2_some_value" & @CRLF & _
"AB_INV_6_some_value" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")