use strict;
my $str = 'AB_INV_23_some_value
AB_INV_234_some_value
AB_INV_23456_some_value
AB_INV_2_some_value
AB_INV_6_some_value
';
my $regex = qr/AB_INV_(?![5-9]_)\d{1,4}_/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}