re = /AB_INV_(?![5-9]_)\d{1,4}_/m
str = 'AB_INV_23_some_value
AB_INV_234_some_value
AB_INV_23456_some_value
AB_INV_2_some_value
AB_INV_6_some_value
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end