using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AB_INV_(?![5-9]_)\d{1,4}_";
string input = @"AB_INV_23_some_value
AB_INV_234_some_value
AB_INV_23456_some_value
AB_INV_2_some_value
AB_INV_6_some_value
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}