#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*\sv((\d+\.)?(\d+\.)?(\d+)).*$"
Local $sString = "Hugo Static Site Generator v0.69.2/extended linux/amd64 BuildDate: 2020-04-27T13:03:45Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")