re = /^.*\sv((\d+\.)?(\d+\.)?(\d+)).*$/
str = 'Hugo Static Site Generator v0.69.2/extended linux/amd64 BuildDate: 2020-04-27T13:03:45Z'
# Print the match result
str.match(re) do |match|
puts match.to_s
end