const regex = new RegExp('^.*\\sv((\\d+\\.)?(\\d+\\.)?(\\d+)).*$', '')
const str = `Hugo Static Site Generator v0.69.2/extended linux/amd64 BuildDate: 2020-04-27T13:03:45Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}