$re = '/^.*\sv((\d+\.)?(\d+\.)?(\d+)).*$/';
$str = 'Hugo Static Site Generator v0.69.2/extended linux/amd64 BuildDate: 2020-04-27T13:03:45Z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);