import re
regex = re.compile(r"^.*\sv((\d+\.)?(\d+\.)?(\d+)).*$")
test_str = "Hugo Static Site Generator v0.69.2/extended linux/amd64 BuildDate: 2020-04-27T13:03:45Z"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")