package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name="csrfmiddlewaretoken"\svalue="\s?(\w+)"`)
var str = `<input type="hidden" name="csrfmiddlewaretoken" value="mfvj33UuJiX9sjoKhhJMZENQjLwLKUlFlUeRLmhQ3DXNTOmggftnMJRvZlbTtNTg">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}