$re = '/name="csrfmiddlewaretoken"\svalue="\s?(\w+)"/m';
$str = '<input type="hidden" name="csrfmiddlewaretoken" value="mfvj33UuJiX9sjoKhhJMZENQjLwLKUlFlUeRLmhQ3DXNTOmggftnMJRvZlbTtNTg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);