// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)name="csrfmiddlewaretoken"\svalue="\s?(\w+)""#).unwrap();
let string = "<input type=\"hidden\" name=\"csrfmiddlewaretoken\" value=\"mfvj33UuJiX9sjoKhhJMZENQjLwLKUlFlUeRLmhQ3DXNTOmggftnMJRvZlbTtNTg\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}