#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+\$$"
Local $sString = "Foo" & @CRLF & _
"Foo1" & @CRLF & _
"Foo$" & @CRLF & _
"$Foo" & @CRLF & _
"1Foo" & @CRLF & _
"1$" & @CRLF & _
"20$" & @CRLF & _
"1$Foo" & @CRLF & _
"12$$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")