import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]+\\$$";
final String string = "Foo\n"
+ "Foo1\n"
+ "Foo$\n"
+ "$Foo\n"
+ "1Foo\n"
+ "1$\n"
+ "20$\n"
+ "1$Foo\n"
+ "12$$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}