package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+\$$`)
var str = `Foo
Foo1
Foo$
$Foo
1Foo
1$
20$
1$Foo
12$$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}