import re
regex = re.compile(r"^[0-9]+\$$", flags=re.MULTILINE)
test_str = ("Foo\n"
"Foo1\n"
"Foo$\n"
"$Foo\n"
"1Foo\n"
"1$\n"
"20$\n"
"1$Foo\n"
"12$$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")