$re = '/^[0-9]+\$$/m';
$str = 'Foo
Foo1
Foo$
$Foo
1Foo
1$
20$
1$Foo
12$$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);