#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\/\/.*)|(?:\'(?:[^\'\\\\]|\\\\.)*+\'|"(?:[^"\\\\]|\\\\.)*+")|(?:import\s*(?:(?:\*\s*as\s+\w+|[\w\s{},*]+)\s*from\s*)?|\bimport\()\s*[\'"`](\.\/[^\'"`]++|(\.\.\/)*+[^\'"`]++)[\'"`]\s*[;\)]?"
Local $sString = "import {myFunction} from "other";" & @CRLF & _
"import*as t from"@popperjs/core";" & @CRLF & _
"" & @CRLF & _
"console.log('import*as t from"@popperjs/core";'); import*as t from"@popperjs/core";" & @CRLF & _
"" & @CRLF & _
"import*as t from"@popperjs/core"; console.log('import*as t from"@popperjs/core";'); " & @CRLF & _
"" & @CRLF & _
"// import" & @CRLF & _
"import 'bar.js';" & @CRLF & _
"" & @CRLF & _
"import" & @CRLF & _
"'bar.js';" & @CRLF & _
"" & @CRLF & _
"// import" & @CRLF & _
""bar.js";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")