$re = '/(?:\/\/.*)|(?:\'(?:[^\'\\\\\\\\]|\\\\\\\\.)*+\'|"(?:[^"\\\\\\\\]|\\\\\\\\.)*+")|(?:import\s*(?:(?:\*\s*as\s+\w+|[\w\s{},*]+)\s*from\s*)?|\bimport\()\s*[\'"`](\.\/[^\'"`]++|(\.\.\/)*+[^\'"`]++)[\'"`]\s*[;\)]?/m';
$str = 'import {myFunction} from "other";
import*as t from"@popperjs/core";
console.log(\'import*as t from"@popperjs/core";\'); import*as t from"@popperjs/core";
import*as t from"@popperjs/core"; console.log(\'import*as t from"@popperjs/core";\');
// import
import \'bar.js\';
import
\'bar.js\';
// import
"bar.js";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);