use strict;
my $str = 'import {myFunction} from "other";
import*as t from"@popperjs/core";
console.log(\'import*as t from"@popperjs/core";\'); import*as t from"@popperjs/core";
import*as t from"@popperjs/core"; console.log(\'import*as t from"@popperjs/core";\');
// import
import \'bar.js\';
import
\'bar.js\';
// import
"bar.js";';
my $regex = qr/(?:\/\/.*)|(?:\'(?:[^\'\\\\]|\\\\.)*+\'|"(?:[^"\\\\]|\\\\.)*+")|(?:import\s*(?:(?:\*\s*as\s+\w+|[\w\s{},*]+)\s*from\s*)?|\bimport\()\s*[\'"`](\.\/[^\'"`]++|(\.\.\/)*+[^\'"`]++)[\'"`]\s*[;\)]?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}