package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/\/.*)|(?:\'(?:[^\'\\\\]|\\\\.)*+\'|"(?:[^"\\\\]|\\\\.)*+")|(?:import\s*(?:(?:\*\s*as\s+\w+|[\w\s{},*]+)\s*from\s*)?|\bimport\()\s*[\'"`](\.\/[^\'"`]++|(\.\.\/)*+[^\'"`]++)[\'"`]\s*[;\)]?`)
var str = `import {myFunction} from "other";
import*as t from"@popperjs/core";
console.log('import*as t from"@popperjs/core";'); import*as t from"@popperjs/core";
import*as t from"@popperjs/core"; console.log('import*as t from"@popperjs/core";');
// import
import 'bar.js';
import
'bar.js';
// import
"bar.js";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}