using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/\/.*)|(?:\'(?:[^\'\\\\]|\\\\.)*+\'|""(?:[^""\\\\]|\\\\.)*+"")|(?:import\s*(?:(?:\*\s*as\s+\w+|[\w\s{},*]+)\s*from\s*)?|\bimport\()\s*[\'""`](\.\/[^\'""`]++|(\.\.\/)*+[^\'""`]++)[\'""`]\s*[;\)]?";
string input = @"import {myFunction} from ""other"";
import*as t from""@popperjs/core"";
console.log('import*as t from""@popperjs/core"";'); import*as t from""@popperjs/core"";
import*as t from""@popperjs/core""; console.log('import*as t from""@popperjs/core"";');
// import
import 'bar.js';
import
'bar.js';
// import
""bar.js"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}