#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^,]*\[[^][]*])+[^,]*|[^,]+"
Local $sString = "year:2020,concepts:[ab553,cd779],publisher:elsevier" & @CRLF & _
"year:2020,concepts:[ab553,cd779]jk,publisher:elsevier" & @CRLF & _
"year:2020,concepts:[ab553,cd779]jk[test].kjkj,publisher:elsevier" & @CRLF & _
"year:2020,concepts:[ab553,cd779]jk[test].kjk[j,publisher:elsevier" & @CRLF & _
"year:2020,concepts[,:],publisher:elsevier" & @CRLF & _
"year:2020,concepts:[ab553,cd779][t,est][].kj,kj,publisher:elsevier[,],],[,][,kk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")