import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^,]*\\[[^][]*])+[^,]*|[^,]+";
final String string = "year:2020,concepts:[ab553,cd779],publisher:elsevier\n"
+ "year:2020,concepts:[ab553,cd779]jk,publisher:elsevier\n"
+ "year:2020,concepts:[ab553,cd779]jk[test].kjkj,publisher:elsevier\n"
+ "year:2020,concepts:[ab553,cd779]jk[test].kjk[j,publisher:elsevier\n"
+ "year:2020,concepts[,:],publisher:elsevier\n"
+ "year:2020,concepts:[ab553,cd779][t,est][].kj,kj,publisher:elsevier[,],],[,][,kk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}