// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^,]*\[[^][]*])+[^,]*|[^,]+").unwrap();
let string = "year:2020,concepts:[ab553,cd779],publisher:elsevier
year:2020,concepts:[ab553,cd779]jk,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjkj,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjk[j,publisher:elsevier
year:2020,concepts[,:],publisher:elsevier
year:2020,concepts:[ab553,cd779][t,est][].kj,kj,publisher:elsevier[,],],[,][,kk
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}