re = /(?:[^,]*\[[^][]*])+[^,]*|[^,]+/m
str = 'year:2020,concepts:[ab553,cd779],publisher:elsevier
year:2020,concepts:[ab553,cd779]jk,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjkj,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjk[j,publisher:elsevier
year:2020,concepts[,:],publisher:elsevier
year:2020,concepts:[ab553,cd779][t,est][].kj,kj,publisher:elsevier[,],],[,][,kk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end