using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^,]*\[[^][]*])+[^,]*|[^,]+";
string input = @"year:2020,concepts:[ab553,cd779],publisher:elsevier
year:2020,concepts:[ab553,cd779]jk,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjkj,publisher:elsevier
year:2020,concepts:[ab553,cd779]jk[test].kjk[j,publisher:elsevier
year:2020,concepts[,:],publisher:elsevier
year:2020,concepts:[ab553,cd779][t,est][].kj,kj,publisher:elsevier[,],],[,][,kk
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}