# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\w{2}(?=\w*$))\K\w(?=\w{2})/*/gm;t' <<< "ABCEDFG"