re = /(?:\G(?!^)|\w{2}(?=\w*$))\K\w(?=\w{2})/m
str = 'ABCEDFG'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result